International Verification Downtime
Incident Report for Lob
Resolved
This incident has been resolved.
Posted 6 months ago. Nov 19, 2017 - 15:59 PST
Identified
There is an issue affecting International Verifications that has been identified. US Verifications continue to function as expected.
Posted 6 months ago. Nov 19, 2017 - 12:32 PST