Network Downtime
Incident Report for Lob
Resolved
This incident has been resolved.
Posted almost 2 years ago. Jun 22, 2016 - 15:45 PDT
Identified
Working to resolve network issues affecting the API.
Posted almost 2 years ago. Jun 22, 2016 - 15:28 PDT