Lob.com and Dashboard Outage
Incident Report for Lob
Resolved
This issue has been resolved.
Posted 9 months ago. May 17, 2017 - 19:20 PDT
Investigating
Lob.com and Dashboard are not functioning - the issue is currently being investigated. The API is fully functional.
Posted 9 months ago. May 17, 2017 - 19:01 PDT